Tyro Service Status for Partners

HealthPoint

Incident Report for Tyro Service Status for Partners

Resolved

HealthPoint is no longer experiencing issues and claims should be processing as normal.
Posted Feb 17, 2025 - 13:21 AEDT

Monitoring

We’re aware that HealthPoint is currently experiencing issues, which may be affecting their claims from being processed.
While this issue is outside Tyro's control, we’re actively monitoring the situation and will provide updates as they become available.
Posted Feb 17, 2025 - 12:20 AEDT
This incident affected: Healthpoint.