Tyro Service Status for Partners

Tyro's phone system

Incident Report for Tyro Service Status for Partners

Resolved

This incident has been resolved.
Posted Jun 20, 2025 - 20:08 AEST

Monitoring

We have communicated to customers via the Status Page that if they have recently tried to contact Tyro's Customer Support, to please call using 1300 00 8976 to speak with us.
Posted Jun 20, 2025 - 17:07 AEST

Identified

We’ve identified an issue with Tyro's phone system. The team are looking into this urgently and will provide further updates as soon as possible. If customers need to get in contact with Tyro urgently, please direct them to contact us via email - cs@tyro.com.

We’re sorry for any inconvenience being experienced.
Posted Jun 20, 2025 - 16:03 AEST