Tyro Service Status for Partners

Transaction processing

Incident Report for Tyro Service Status for Partners

Resolved

The earlier issue impacting some customers’ ability to process transactions has now been resolved.

We’re sorry for any inconvenience experienced.
Posted Dec 11, 2025 - 17:57 AEDT

Identified

An issue has been identified with some customers experiencing issues processing transactions. The team are working to resolve this issue as quickly as possible, and we’ll continue to provide updates.

In the meantime, please try rebooting your terminal or connecting to WiFi by following these steps:

https://help.tyro.com/s/article/How-to-reboot-the-Tyro-Pro

https://help.tyro.com/s/article/How-do-I-reboot-my-Tyro-EFTPOS-machine

https://help.tyro.com/s/article/How-to-connect-a-Tyro-EFTPOS-machine-to-WiFi

We’re sorry for any inconvenience being experienced.

Please feel free to use this information if you’re receiving enquiries from merchants and encourage them to visit status.tyro.com for updates.
Posted Dec 11, 2025 - 10:20 AEDT
This incident affected: EFTPOS Machine Connectivity.